I suggest you ...

fix UPnP.

UPnP does not work when I know it works on the router...

79 votes
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    I agree to the terms of service
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    thals1992thals1992 shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

    16 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      I agree to the terms of service
      Signed in as (Sign out)
      Submitting...
      • punjapunja commented  ·   ·  Flag as inappropriate

        what if the device is not upnp enabled, will downloads still work? torrent downloads are restricted in my location.

        after 'querying downloads' the message displayed is 'could not start download'

      • thals1992thals1992 commented  ·   ·  Flag as inappropriate

        Windows 7 Home Premium now says
        "Could not find any UPnP enabled gateway device."
        Same thing with Windows Server 2008 R2.... Checked the router, it says it is enabled and windows detects it in the windows map.

        Router is now WRT610N V1

      • thals1992thals1992 commented  ·   ·  Flag as inappropriate

        It works on every unit I have used now - WRT54g, BEFW11S4 (Linksys Wireless-B), and my crappy WCG200.

        Thanks for cleaning up the problems.

      • fcecinfcecin commented  ·   ·  Flag as inappropriate

        Well, I just rebooted (win xp sp2) and before doing anything else "netstat -a -b -v" gives me this:

        TCP n-f130aa40c7864:2869 n-f130aa40c7864:0 LISTENING 1436
        C:\WINDOWS\system32\httpapi.dll
        c:\windows\system32\ssdpsrv.dll
        C:\WINDOWS\system32\RPCRT4.dll
        [svchost.exe]

        This looks to me like svchost.exe (a windows process) is already sucking up any incoming TCP connection attempts at local port 2869. So naturally if say a java applet tries to open a TCP socket for listening at 2869 after windows boot, it won't be able to, never ever.

        I don't actually know anything about how UPnP works (I was hoping I didn't have to...) but so far it seems to depend on hardcoded port numbers 1900 UDP and 2869 TCP to work from the machine that is supposed to talk to the router. These ports are from the windows firewall option that enables UPnP.

      • fcecinfcecin commented  ·   ·  Flag as inappropriate

        I'm getting the "java.net.BindException: Address already in use: Cannot bind".

        If that happens to be due to rebind attempt at local port 1900 UDP then maybe you can use DatagramSocket.setReuseAddress( true ); to solve or at least move the problem elsewhere.

        If it is on the TCP listening socket (2869?), then provided you closed the previous listening socket earlier before the rebind attempt you can avoid the previous listening socket from lingering around with Socket.setSoLinger( "zero-seconds" ) -- again that should at least move the problem elsewhere.

        Are you using the sbbi UPnPLib 1.04? I'm trying to get that to work here too; I'm also trying to do UPnP from a signed applet. No luck so far.

      • tailoriantailorian commented  ·   ·  Flag as inappropriate

        Router: Thomson TWG850-4U
        UPnP page error: java.net.BindException: Address already in use: Cannot bind

      • CareyCarey commented  ·   ·  Flag as inappropriate

        I have the same issue with a SMC Barracuda, also with UPnP enabled.

      • zarnmonsterzarnmonster commented  ·   ·  Flag as inappropriate

        I get this error
        "java.net.BindException: Address already in use: Cannot bind"
        I have D-Link G604T which has uPnP turned on

      Feedback and Knowledge Base